• SAPUI5日期时间的处理

    SAPUI5日期时间的处理

    在JS中,我们可以使用new Date(),来得到前端的日期(时间),但此得到的时间格式化为如:Fri Jan 22 2021 15:08:32 GMT+0800 (中国标准时间),这数据使用起来明显不太方便,我们可能会想得到标准的SAP格式20210122,又或者2021-01-22等等。所以我们就需要在得到一个日期对像时进行转换,或者把一个字符串转换成日期对像。 Continue reading …
  • odata中Function Imports的使用

    odata中Function Imports的使用

    在做SAPUI5开发时,我们会需要做的特定的ACTIONS动作操作,比如,把选定的行进行采购收货,交货,或者做发票校验等操作,这些操作,我们都需要在SAP Gateway做好后端开发,也就是做ODATA的对应功能,给前端SAPUI5使用。做ODATA时,我有三个想法, 1.使用Entity的CREATE方法,在POST的方法中实现,但测试后现发在前端OMODEL.create时,只能提交单行,而在一些操作时,我们所需要的是一次提交多行,所以此方法没成,也考虑在PUT,MERGE中实现,但还没测试,不过,可能性很小,应该也不行。 2.使用Function Imports,此法在SEGW中创建一个Function 的功能来给前端调用,此文章主要介绍此法。 Continue reading →
2020
09-14

关于PI调用ECC时ECC的操作方法 HOT

关于PI调用ECC时ECC的操作方法 在零售企业中,大多时间会采用SAP的接口中间PI(早期叫XI,现在取名PO,不过我还是习惯叫PI).在PI与SAP连接时,一般有三种方式:IDOC,RFC,PROXY。 IDOC对标准业务是优选 IDOC使用的应该是最稳定的,对于一些标准业务来说,可能使用IDOC可能是最好的选择,并且IDOC本身有很好的日志及重处理机制,所以在使用时,我们可以完整的使用IDOC的优势,但对于自定义的功能,使用IDOC,就要做太多工作了,相对快速开发来说,可能不会是好选择。 RFC不太稳定,感....Read More >
2020
08-30

不显示launchpad Head HOT

不显示launchpad Head 今天在做一个二级用户登陆的功能时,默认当使用把App as Fiori Component运行时,总是带出Launchpad的抬头项目,如图 我的想法是二级用户登陆后,默认的这个HEAD就不需要了,要使用自己下面这一级的用户登陆信息,所以需要隐藏默认的HEAD, 在SAP网上找到如下代码, [crayon-600bfb4e01aea248397252/] 把此两行代码写到,Component.js文件中,如图 执行后,结果如下,默认的HEAD就不在....Read More >
2020
08-24

SAP Web IDE 增加一个新SAPUI5版本 HOT

SAP Web IDE 增加一个新SAPUI5版本 这几天想做一个,SAP FIORI 二级登陆的功能,也就是SAP标准用户登陆后,又可以使用自定义维护的用户登陆,这样就可以在FIORI APP统一一个SAP用户名,然后使用自定义用户登陆,这样节省了SAP用户授权费用,但在使用时我需要使用sap/ui/util/Storage来做Session处理,发现当前SAP WEB IDE自带的版本最大只1.52.13,没有这类,所以就想在SAP WEB IDE Personal Edition中增加最新SAPUI5版本,当前最新版本是,1.80.0,所....Read More >
2020
08-19

SAP WEB IDE编辑器报错 HOT

SAP WEB IDE编辑器报错 在SAP WEB IDE 做SAPUI5开发时,报错: Best practices. ESLint(linebreak-style):Expected linebreaks to be 'CRLF' but found 'LF' 此报错,只是在编辑器上报错,但不影响程序APP的运行。 解决办法 在APP工程项目上,右键,属性设置(Project settings),图中,我原因的值是“UNIX”,把此值修改为WINDOWS后,现使用正常。 终极办....Read More >
2020
08-13

FIORI 服务器安装配置与安装 HOT

FIORI 服务器安装配置与安装 在BASIS安装完成SAP 服务器后,为了使用FIORI ,Gateway OData等功能时,需要一些设置。由于每天服务器,BASIS安装的程度可能不以样,细节得自己查看,以下以是我对HANA S4的一个服务器增加配置的过程,以此记录 FIORI服务器版本及安装组件需求 组件要求:SAP Gateway 2.0 安装下列组件并升级至最新GW_CORE 200 及其support package;IW_BEP 200及其support package;IW_FND 250及其sup....Read More >